登录 注册

登录

问题 文章不显示,实在搞不定,现有几个疑问想请教站长!

更多
2014年05月30日 22:08 #1 作者: flyjoe
由于之前购买空间时,没想到升级换代的速度如此快,JOOMLA已经升级到3.X的版本
而我购买的空间,仍然只能使用PHP5.2.17版本!!所以挺无奈,在考虑是否另行购买空间!

但在此间调试网站时,不知道自己“干”了什么事?突然部分“文章”就无法显示了??

本身就在学习中,这突然的“打不开”实在令小白头疼,希望站长能协助“复原”一下!!感谢

我的链接是www.sh-elite.com

管理密码另PM!!

开启调试模式后,出现这样的情况



希望可以获得站长的协助,感谢。。。
附件:

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年05月31日 07:07 #2 作者: Joomla之门
从截图上看,似乎是找不到 Phoca Font 组件对应的数据表导致的。

你可以到后台的“扩展 -> 插件管理”里面,找到一个系统插件,名称可能是“Phoca Font Plugin”,将它禁用,前台就不会加载 Phoca Font 相关代码了,也就不再去寻找那个数据表。

如果想继续使用 Phoca Font,可以下载最新版本再安装一次该组件,或许数据表就重建了。

最后的办法,就是用你网站最新的备份包来还原。当然,或许不用走到这一步就弄好了。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年05月31日 07:17 #3 作者: Joomla之门
刚刚收到你发来的管理员账号,进入网站后台看了一下,明白了真正的原因:

你的网站核心是 Joomla 2.5,对应的 Phoca Font 版本是 2.0.2, 但是 Phoca Font 作者在 2.x 及之前的版本有一个变态的设计,就是当你安装的时候,在后台点击了“上传并安装”按钮之后,Phoca Font 显示的欢迎画面上,还有一个“安装”按钮。很多人忘记了点击那个按钮,那么,就等于 Phoca Font 组件实际上并未安装完成 —— 数据表还未创建,仅仅是创建了后台“组件”菜单上的名称而已。

因此,解决的办法很简单:重新安装一次 Phoca Font v2.0.2,我已经帮你操作过了,这次我点击了它自带的“安装”按钮,数据表应该已经创建好了。Phoca Font Plugin 插件也无需禁用了,因为你应该是想继续使用这个扩展的。

由于你前面发帖时没有提供出错页面的网址,所以我无法验证该页面现在是否能正常打开。你自己访问一下那个页面试试,如果还有问题,继续跟帖讨论。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年06月06日 15:52 - 2014年06月06日 15:55 #4 作者: flyjoe
感谢白站的回复!
最后决定,网站重新来过!
既然重新安装,就要知道自己做了些什么。。。我偷偷告诉白站啊。。。。

就是下面这个【家伙】惹的祸。。。。





已经三次重新安装了。。。每次更新完这个插件。。。网站就一切空白。。。

实在有点无语,日后若见到更新,都不知道该不该点击【更新】了???

望请站长【查明真像】,感谢!!
附件:
最后修改: 2014年06月06日 15:55 由 flyjoe. 原因: 多说一点。。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年06月06日 17:30 #5 作者: Joomla之门
如果升级 T3 插件就导致出错,最大可能是:你目前所用的模板是旧版本,其 T3 插件的名称是 plg_system_jat3 ,而最新的 T3 框架已变成了 plg_system_t3 。这两个之间不能直接升级,必须等官方进行模板全面升级之后才行。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年06月07日 22:01 #6 作者: flyjoe
折腾到现在,无法查明什么原因,反复安装和更新。。。下载官方的原始文件安装。。。

仍然无法在我购买的主机上正常显示!

打开“调试模式”后,显示以下内容:

Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or '$' in F:\webhost002\flyjoe\web\plugins\system\t3\includes\joomla25\layout\file.php on line 433

一会用FTP下载下来看看 433 的内容。。。。

但在本机 xampp 搭建的环境下。。。貌似没有这么多的问题,不得不怀疑购买的主机搭建的环境问题!!

但参考了白站使用主机 bithost.cn !。。。貌似我感觉速度也不太稳定!(时好,时不好)
不知道是我的网络问题,还是。。。。

本来想参考学习其他布景主题的安装,但貌似RT,JR的主题安装方式各有所异,希望白站可以指点我一些明路,
来学习这二类主题安装的方法和步骤!感谢

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年06月07日 22:03 #7 作者: Joomla之门
你告诉我你所用的那个 JA 模板的名称,我来测试一下。

另外,你为什么不考虑用 Joomla 3 ?Joomla 2.5 已经过时了。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年06月07日 22:18 - 2014年06月07日 22:41 #8 作者: flyjoe
*
	 * @return  string  The necessary HTML to display the layout
	 *
	 * @since   3.2
	 */
	public function sublayout($layoutId, $displayData)
	{
		// Sublayouts are searched in a subfolder with the name of the current layout
		if (!empty($this->layoutId))
		{
			$layoutId = $this->layoutId . '.' . $layoutId;
		}
 
		$sublayout = new static($layoutId, $this->basePath, $this->options);<-------------------------433
		$sublayout->includePaths = $this->includePaths;
 
		return $sublayout->render($displayData);
	}
}
上面右侧,写433,的位置就是出错的位置,(小白我看不懂)
不是我不考虑用joomla3,是主机只到php5.2X 不支持joomla3的系统(有试过)

所以我在考虑另外购买虚拟主机的空间,前提是要对未来的支持度要高一点。。。
(想的太多,所以无从下手,又不太懂,又怕被忽悠)呵呵

所使用的是官方下载的 jatc_t3v2_blank_j25.zip 文件
感谢白站!
最后修改: 2014年06月07日 22:41 由 Joomla之门. 原因: 添加 code 标记

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年06月07日 22:49 #9 作者: Joomla之门
t3v2 实际上是旧版本,新框架是 T3 (不带 V)。新的 T3 Framework 也有针对 Joomla 2.5 的示范(空白)模板,下载地址:

如果你是在现有的 Joomla 2.5 网站上安装,需要下载两个文件:

T3 BS3 Blank Template T3 Framework plugin

如果你还没有任何网站,那么直接用 quickstart 来体验吧:

T3 Quickstart for Joomla 2.5

顺便说一下,你可以要求主机商将 PHP 升级到 5.3.10,然后就可以享用 Joomla 3 了。

如果主机上的 PHP 无法升级,那就换主机,顶多损失几百块钱,但是网站能得到很大提升。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年07月06日 15:00 #10 作者: zheng512008
问下白站长,为什么要用joomla3 !? 我认为joomla 3很强大,很便捷 ,但有一个现实问题,joomla3 后台默认调用google服务,好像是调用 google的jquery-1.8.3.min.js,导致点一个选项要反应好长时间。前台还好解决,可以在建站时不用或关闭google服务。在中国访问,就仅这一点,让我不再敢用joomla 3,2.5就不存在这一问题。

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年07月06日 15:00 #11 作者: zheng512008
本人正在研究T3框架,有兴趣的可以一起学习交流。zheng512008@163.com

登录 或者   注册一个会员帐号 来参与讨论