登录 注册

登录

已解决 网站安全与使用程序的版本关系

更多
2014年12月07日 11:43 - 2015年01月20日 16:31 #1 作者: likunzhou
我知道PHP版本不是越高越好,因为会有兼容性问题。不同版本功能有一定差别,但我很想知道低版本的PHP或Apache,MySQL,phpMyAdmin等对整个站点的安全有什么影响。
我想自己搭建服务器(非测试),在安全方面应该怎么做?希望白老师做个扫盲贴
最后修改: 2015年01月20日 16:31 由 likunzhou.

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年12月07日 12:33 #2 作者: Joomla之门
我自己对服务器配置一窍不通,我只是一个热爱 Joomla 的用户。

根据 Joomla 官方的要求,Joomla 3.3 系列的核心,运行必须的 PHP 版本至少要高于 5.3.10 ;而根据我们的体验 ,PHP 版本一旦高于 5.5 就很容易出错;再根据官方的计划,不久的将来发布的 Joomla 3.4 系列要求 PHP 版本至少要高于 5.4.0 。

因此,我得出一个结论:在现阶段(Joomla 3.3.x - 3.4.x ),服务器的 PHP 版本最好设在 5.4.0 至 5.4.35 之间

我想,合适的 PHP 版本,不仅仅对网站的安全是一个保障,同时对 CMS 核心及其扩展的正常运行也是一种保障。

我站在一个普通用户/站长的角度,我的看法是:我没时间去研究那么多深层次的理论,既然 PHP 5.4.x 不高不低刚刚好,那我就用这个版本。其它的事情暂且不用去想,省下时间好好做网站的内容。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年12月07日 12:35 #3 作者: Joomla之门
我在 XAMPP 服务器包下载页面 推荐并强烈提醒大家使用 XAMPP 1.8.2 版本,就是因为这个版本提供的 PHP 版本是 5.4.27,如果你安装最新的 XAMPP 1.8.3,其 PHP 版本就成了 5.5.x;假设 XAMPP 继续发布新版本,可以预见以后的 PHP 都是高于 5.5 的。

所以,如果大家搭建测试服务器,在现阶段(Joomla 3.3.x - 3.4.x),务必选择 XAMPP 1.8.2 版本。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论